Metasploit med databasstöd i Snow Leopard

Ja, efter många om och men så installerade jag ju lite olika varianter av MySQL och stötte på lite olika problem. Nu verkar jag dock ha löst alla problem och det rullar på som det ska.

Lösningen var att inte installera något av MaxOSX-paketen från mysql.com utan att kompilera allt från source. Direkt jag hade gjort det och satt rätt rättigheter på data-katalogen så kunde jag starta mysqld_safe utan problem.

När det väl var gjort så kunde jag köra “gem install mysql” utan andra växlar.

Sen var det inga som helst problem att köra db_driver, db_connect, db_nmap och db_autopwn. ;)


Leave a Reply

Your email address will not be published. Required fields are marked *